2.2.1で日本語化ができない

  1. 2年前

    Mautic 2.2.1にバージョンアップしたところ、日本語化ができなくなってしまいました。
    Mautic自体の設定及び、ユーザアカウント側の設定も日本語(時間も東京)を選択しても日本語されません。

    以前までのMauticのバージョンは不明ですが、インストール後間もなく2.2.1が出たので、
    一旦以前のバージョンを削除して2.21を入れ直しました。

    2.2.1が日本語対応されていないなどが有るのでしょうか?
    原因など検討つくことがありましたらご教授をいただきたいです。

     検証実験の結果報告が遅くなって申し訳ありません(※Mauticは自分の本業ではないため、業務が終了して帰宅してから検証作業を行っております)。

     こちらでは以下の環境で実験してみました。

     ホスト:heteml
     アップロードに使ったPC:Windows7
     アップロードに使ったFTPソフト:FFFTP 1.99a
     使用したPHP:5.6 CGI版 および 7.0 CGI版
     使用したブラウザ:IE11 および Google Chrome

     事前にローカルで展開して、それをアップロードしてからWeb画面での設定を行いました。
     また、上記の他に zip でアップロードしてから、ホスト側で展開するパターンも実験しました。
     ※ドキュメントルート(「web」ディレクトリ)の下に1階層作成して、その中にアップロードしました。

     こちらの環境では、zipファイルをアップロードしてホスト側で展開した場合に「日本語に設定しても反映されない」事象が再現されましたが、Mautic側(=ホスト側)のキャッシュをクリアすることで、日本語に正しく設定されるようになりました。

     つきましては、キャッシュクリアを行うため、以下の方法を試して頂ければと思います。

     1.Mautic のダッシュボードから Japanese 、タイムゾーンを Tokyo/Asia にして Apply をクリックします。
     2.いったんログアウトします。
     3.FTP ソフトで Mautic のインストールされているディレクトリにアクセスします。
     4.app のディレクトリに移ります。
     5.cache のディレクトリに移ります。
     6.prod というディレクトリがありますので、prod_old などの別の名前に変更します。
     ※prod ディレクトリがキャッシュディレクトリなので削除しても大丈夫なはずですが、念のため別の名前にしています。

     この状態で、WebブラウザでMauticのログオン画面あるいはダッシュボードを表示させてみてください。

    -image-

     正しく日本語で表示されたら、残しておいた prod_old のディレクトリをFTPソフトで削除します。

     なお、私の環境では php.ini について初期値から変更している個所がありますので、スクリーンショットを参考までにアップロードします(※現状で特に問題なく動いているのであれば、特に変えなくてよいと思います)。

    -image-

    -image-

     なお、ファイルのパーミッションについても合わせて調査を行いました。あらかじめローカルで展開してからアップロードした場合と、zip でアップロードしてから展開した場合とで、若干の違いがあるようです。

    ローカルで展開してアップした時
    -image-

    zipでアップロードしてホスト側で展開した時
    -image-

     ですが、いずれの場合もセットアップは通常通り行えました。

  2. J_Kataama

    11 Nov 2016 Administrator

    Mautic 2.1.1 から、設定画面で言語設定を「Japanese」を選択して Apply を押しても、(バグなのか)その瞬間には日本語表示に変わってくれません。

    その状態でいったんログアウトして、改めてMauticにログインして頂くと日本語になっているのではないかと思います(※ログアウト後のログイン画面から日本語になっているかと・・・)。

    よろしくお願いいたします。

  3. ご返信ありがとうございます。

    >>Mautic 2.1.1 から、設定画面で言語設定を「Japanese」を選択して Apply を押しても、(バグなのか)その瞬間には日本語表示に変わってくれません。
    確かに以前のバージョンでは気づいたら日本語になっていたので、しばらく時間おいたらと思っていましたが、
    時間をおいても、Mauticを開いた事がないブラウザを使ってもダメでした。
    ログアウトしてもダメでした…

    ちなみにインストール時に、ローカルで解凍したMautic本体をFTPでアップロードしておりますが、その影響でパーミッション?などが違っているなども想像したのですが、どうなのでしょうか…
    以前のバージョンは同じやり方で上手くいっていたので、関係ないかもしれませんが…

  4. J_Kataama

    15 Nov 2016 Administrator
    2年前はJ_Kataamaによって編集されました

     いくつか確認する場所はあると思いますが、まずは

    1.ログオン後の右上の歯車マークをクリック
    2.Setting の中の System Info をクリック
    3.左側にある Folder & Permissions をクリック

     で表示される項目が全て Writable になっているかを確認して頂けますでしょうか。
     また、日本語に設定して Apply を押した直後に、System Info の画面での Log に何か出ていますでしょうか。

     なお、ローカルで展開してFTPでアップロードされているとのことですが、可能でしたら

     ・ローカルコンピュータのOSの種類
     ・お使いのFTPソフトウェア
     ・FTPで使用しているアカウント(=権限)が何か(おそらくは管理者権限ありの状態だとは思いますが・・・)
     ・アップロード先ホストがホスティング or オンプレミスか(※どこかのホスティングサービスを利用されている場合にはお知らせ頂ければ助かります)
     ・アップロード先のOSの種類
     ・アップロード先のディレクトリ階層
     ・Webサーバのドキュメントルートの場所(直接のアップロード先と異なるかどうか)

     などを教えて頂ければ幸いです。

     お手数をおかけいたしますが、よろしくお願いいたします。

  5. 分かる範囲で解答いたします。
    何卒よろしくお願いいたします。

    ・Folder & Permissions → Writable全て確認しました。
    ・System Info → Log

    [2016-11-15 23:27:56] mautic.ERROR: Deprecation: The alias option of the form.type_extension tag of service "fos_rest.form.extension.csrf_disable" is deprecated since version 2.8 and will be removed in 3.0. Use the extended_type option instead. - in file /hogehoge/mautic/vendor/symfony/framework-bundle/DependencyInjection/Compiler/FormPass.php - at line 67 [] []

    ・ローカルコンピュータのOSの種類
     → Mac OS X El Capitan
    ・お使いのFTPソフトウェア
     → FileZilla
    ・FTPで使用しているアカウント
     → hetemlのメインFTPアカウント 
    ・アップロード先ホスト
     → heteml
    ・アップロード先のOSの種類
     → 不明
    ・アップロード先のディレクトリ階層
     → /ドメインのフォルダ/moutic/

  6. J_Kataama

    15 Nov 2016 Administrator

    ご返信ありがとうございます。

    お使いのheteml(https://heteml.jp/)では11月30日まで無料期間らしいので、こちらでもMautic 2.2.1 を入れて、再現してみたいと思います。

    つきましては、少々お時間を頂きたいと思いますが、何卒よろしくお願いいたします。

  7. J_Kataama

    17 Nov 2016 Administrator Answer
    2年前はJ_Kataamaによって編集されました

     検証実験の結果報告が遅くなって申し訳ありません(※Mauticは自分の本業ではないため、業務が終了して帰宅してから検証作業を行っております)。

     こちらでは以下の環境で実験してみました。

     ホスト:heteml
     アップロードに使ったPC:Windows7
     アップロードに使ったFTPソフト:FFFTP 1.99a
     使用したPHP:5.6 CGI版 および 7.0 CGI版
     使用したブラウザ:IE11 および Google Chrome

     事前にローカルで展開して、それをアップロードしてからWeb画面での設定を行いました。
     また、上記の他に zip でアップロードしてから、ホスト側で展開するパターンも実験しました。
     ※ドキュメントルート(「web」ディレクトリ)の下に1階層作成して、その中にアップロードしました。

     こちらの環境では、zipファイルをアップロードしてホスト側で展開した場合に「日本語に設定しても反映されない」事象が再現されましたが、Mautic側(=ホスト側)のキャッシュをクリアすることで、日本語に正しく設定されるようになりました。

     つきましては、キャッシュクリアを行うため、以下の方法を試して頂ければと思います。

     1.Mautic のダッシュボードから Japanese 、タイムゾーンを Tokyo/Asia にして Apply をクリックします。
     2.いったんログアウトします。
     3.FTP ソフトで Mautic のインストールされているディレクトリにアクセスします。
     4.app のディレクトリに移ります。
     5.cache のディレクトリに移ります。
     6.prod というディレクトリがありますので、prod_old などの別の名前に変更します。
     ※prod ディレクトリがキャッシュディレクトリなので削除しても大丈夫なはずですが、念のため別の名前にしています。

     この状態で、WebブラウザでMauticのログオン画面あるいはダッシュボードを表示させてみてください。

    -image-

     正しく日本語で表示されたら、残しておいた prod_old のディレクトリをFTPソフトで削除します。

     なお、私の環境では php.ini について初期値から変更している個所がありますので、スクリーンショットを参考までにアップロードします(※現状で特に問題なく動いているのであれば、特に変えなくてよいと思います)。

    -image-

    -image-

     なお、ファイルのパーミッションについても合わせて調査を行いました。あらかじめローカルで展開してからアップロードした場合と、zip でアップロードしてから展開した場合とで、若干の違いがあるようです。

    ローカルで展開してアップした時
    -image-

    zipでアップロードしてホスト側で展開した時
    -image-

     ですが、いずれの場合もセットアップは通常通り行えました。

  8. ご多用の中、そうそうに検証していただきありがとうございます!
    早くても来週だろうなと勝手に思っていたのでとても助かりました。

    そしてキャッシュのクリアで無事日本語化になりました。

    また、その他の設定についてもありがとうございます。
    参考にさせていただきます。

    hetemlでもzipファイルをアップロードしてホスト側で展開することが出来るんですね…
    初めやろうと思ったのですが、出来なくて断念していました。もっと勉強します。

    いずれにせよ、一人では解決できなかったので、本当に助かりました。
    ありがとうございました。

  9. J_Kataama

    18 Nov 2016 Administrator

    お役にたてて良かったです!
    また何かありましたら、お気軽にお気軽にご相談ください(※自分が分かる範囲でですが・・・)。

    今後ともよろしくお願いいたします。

 

または 登録して返信...